微信搜索superit|邀请体验:大数据, 数据管理、OLAP分析与可视化平台 | 赞助作者:赞助作者

No such module ‘SnapKit’”错误

IOS aide_941 21℃

今天在使用SnapKit的时候,出现了“No such module ‘SnapKit’”错误,Podfile文件内容如下:

环境是:macOS 10.13.4,Xcode 9.4,Swift 4.1.2

source ‘https://github.com/CocoaPods/Specs.git’

platform:ios,’11.0′
use_frameworks!

def pods
#Swift
pod ‘Alamofire’, ‘~> 4.0’
pod ‘Kingfisher’, ‘~> 4.0’
pod ‘ObjectMapper’, ‘~> 3.2’
pod ‘SwiftyJSON’, ‘3.1.3’
pod ‘Dollar’, ‘~> 7.1.0’
pod ‘Cent’, ‘~> 7.0.0’
pod ‘KeychainAccess’, ‘~> 3.1.0’
pod ‘UIColor_Hex_Swift’, ‘~> 3.0.2’
pod ‘RxSwift’, ‘~> 4.0’
pod ‘RxCocoa’, ‘~> 4.0’
pod ‘RxBlocking’, ‘~> 4.0’
pod ‘XCGLogger’, ‘4.0.0’
pod ‘SnapKit’, ‘~> 4.0.0’
pod ‘BSImagePicker’, ‘~> 2.7’
pod ‘TSVoiceConverter’, ‘0.1.6’
pod ‘XLActionController’, ‘~> 4.0’
pod ‘TimedSilver’, ‘1.1.0’

#Objective-C
pod ‘YYText’, ‘1.0.7’
pod ‘SVProgressHUD’, ‘2.0.4’
pod ‘INTULocationManager’, ‘4.2.0’
end

target ‘jiaomi’ do
pods
end
———————
作者:wangxiaosu
来源:CSDN
原文:https://blog.csdn.net/wangxiaosu0501/article/details/80634953
版权声明:本文为博主原创文章,转载请附上博文链接!

转载请注明:SuperIT » No such module ‘SnapKit’”错误

喜欢 (0)or分享 (0)